Git SVN Error in SourceTree for Mac after upgrading to OS X Mavericks 10.9

I upgraded my Mac to OS X Mavericks 10.9 yesterday evening and everything has been going well, except for one thing with SourceTree and Git SVN repositories. When attempting to synchronize SVN repositories with SourceTree via Git, the following error occurs:

Can't locate SVN/Core.pm in @INC (@INC contains: 
/Applications/Xcode.app/Contents/Developer/usr/share/git-core/perl 
/usr/../Library/Perl/5.12/darwin-thread-multi-2level 
/usr/share/git-core/perl /Library/Perl/5.12/darwin-thread-multi-2level 
/Library/Perl/5.12 /Network/Library/Perl/5.12/darwin-thread-multi-2level 
/Network/Library/Perl/5.12 /Library/Perl/Updates/5.12.4 
/System/Library/Perl/5.12/darwin-thread-multi-2level 
/System/Library/Perl/5.12 /System/Library/Perl/Extras/5.12/darwin-thread-multi-2level 
/System/Library/Perl/Extras/5.12 .) at /usr/libexec/git-core/git-svn line 61.

So something’s wrong with OS X’s Perl installation. I couldn’t figure out what exactly, but configuring SourceTree to use your system’s Git installation (instead of SourceTree’s built-in version) seems to do the trick. Here’s how:

  1. Open SourceTree Preferences
  2. Click the “Git” tab
  3. Click the “Use System Git” button

SourceTreePreferences

SourceTreeSystemGit

Advertisements